Condividiamo la conoscenza – costruiamo una BiblioBox

Qualche tempo fa vi avevo parlato della PirateBox un progetto interessantissimo per la condivisione di contenuti didattici in biblioteca e non solo. Da quell’articolo, grazie a quanto già realizzato dall’amico Roberto Marcolin ne ho realizzato un progetto che ho sviluppato insieme all’amico e collega Pier Giuseppe Barbonaglia che nella mia scuola si occupa della gestione della Biblioteca Scolastica.

La PirateBox è diventata la BiblioBox 🙂 ed è funzionante da qualche giorno nella mia scuola. Grande successo tra gli allievi con cui si condividono: riviste tecniche, appunti di studio e tutto ciò che può servire per la didattica e non solo, come ad esempio: musica, letteratura, tutorial informatici (programmazione e hardware) e molto altro, tutto obbligatoriamente open source, legalmente distribuibile.

Un altro modo per far nascere curiosità ed interesse da parte degli allievi.

Secondo le necessità la BiblioBox può cambiare area di azione ed essere allocata in un aula, oppure in un laboratorio o ancora, se serve in lughi diversi dalla scuola.

Questa la breve presentazione del progetto:

La BiblioBox è un dispositivo portatile per la condivisione di contenuti digitali via WiFi all’interno di una rete locale senza bisogno di connessione ad internet. La BiblioBox permette di condividere opere di pubblico dominio, ma anche contenuti distribuiti con licenze Creative Commons o altre licenze aperte, in maniera libera in diversi contesti differenti come ad esempio: biblioteca, lezioni, conferenze, manifestazioni.

Può trovare posto nella borsa del Prof. in modo che gli studenti, mediante i loro dispositivi mobili possano accedere a dispense, presentazioni e tutto ciò che serve per svolgere la lezione:

la-borsa-del-prof

Esempio di contesti applicativi:

  • conferenza in cui il relatore durante la sua esposizione invita le persone a collegarsi alla rete BiblioBox per prelevare contenuti aggiuntivi.
  • Durante una manifestazione (ad es. Salone del Libro, JobOrienta, ecc…) dove nell’area espositiva si vuole offrire alle persone la possibilità di usufruire di una rete libera dove prelevare contenuti digitali. (valorizzazione ed amplificazione del carattere innovativo tecnologico di chi espone).
  • In biblioteca per condividere: libri, riviste, contenuti multimediali non coperti da diritto d’autore, tutti esclusivamente a contenuto didattico o indirizzati all’orintamento scolastico. In questo modo si favorisce l’utilizzo di ebook.
  • Integrazioni con eventuali progetti in cui insegnare agli studenti come si producono e condividono ebook e come si condividono prodotti editoriali digitali.

Il progetto tutela la privacy degli utenti: nessun dato viene raccolto quando l’utente si connette.

Ma quali sono gli obiettivi?

  • Accesso gratuito e protetto alle risorse digitali scolastiche, tutto indirizzato al miglioramento della didattica.
  • Opportunità per creare un’emulazione tra scuole e pubblico nel reperimento e nella promozione dei contenuti digitali.
  • Mostrare che la scuola è un centro di sperimentazione ed innovazione.
  • La valorizzazione dei contenuti multimediali da parte di docenti ed allievi invita a prendere coscienza della forza e dell’importanza dei beni comuni della conoscenza.

Ma quali sono le differenze con una rete WiFi scolastica?

  • accesso libero e gratuito alle risorse didattiche
  • un sistema trasportabile in ogni luogo (fotovideo)
  • sistema completamente protetto
  • chat tra gli utenti della BoblioBox
  • molto economico

Fatta la premessa partiamo con l’attività pratica.

Il seguente tutorial è tratto integralmente dalla guida di Roberto Marcolin a questa io ho aggiunto le immagini che mettono in evidenza le fasi di installazione, (mi è stato chiesto da colleghi e studenti che già stanno usando il dispositivo) inoltre ho aggiunto alcuni dettagli di installazione e ne ho fatto qualche riadattamento veloce all’interfaccia grafica della PirateBox,  il merito del tutto va comunque a Roberto che ringrazio.

Di cosa avete bisogno:

tp-link-mr3020-00

tp-link-mr3020-01

tp-link-mr3020-03

tp-link-mr3020-02

Passo 1

Scaricare una copia di OpenWrt per l’MR3020, per il WR703N, scarica il firmware OpenWrt

Passo 2

Posizionare l’interruttore collocato accanto alla porta LAN/WAN in modalità WISP

tp-link-mr3020-04

Passo 3

Spegnere il wireless del computer portatile (in Mac OSX, fare clic sull’icona wifi e seleziona “Turn Wi-Fi Off”)

bibliobox01

Passo 4

Collegare il router via cavo Ethernet al computer e aprire un browser web alla pagina http://192.168.0.254 (per l’MR3020) oppure http://192.168.1.1 (per la WR703N)

tp-link-mr3020-05

bibliobox02

Passo 5

Immettere nome utente  password di default (admin e admin)

bibliobox03

Facendo click su “Log In” apparirà la pagina:

bibliobox04

Passo 6

Andate nel menù System Tools -> Firmware Upgrade

bibliobox05

Passo 7

Seleziona il firmware OpenWRT che avete scaricato al Passo 1.

bibliobox06

Vi comparirà un messaggio che vi chiede se effettivamente siete sicuri di voler effettuare l’aggiornamento, fate click su “OK”:

bibliobox07

Passo 8

Si avvia l’aggiornamento e al termine il sistema si riavvierà:

bibliobox08

bibliobox09

bibliobox10

Comparirà il messaggio che vi informa che l’upgrade è andato a buon fine, ma l’avanzamento resta bloccato al 99%, non preoccupatevi tutto è andato a buon fine e potete chiudere la finestra del browser.

Passo 9

Collegatevi in Telnet al dispositivo:

telnet 192.168.1.1

ovviamente per poter fare questa operazione il vostro computer deve avere un numero ip compatibile del tipo 192.168.1.XX oppure ponete in dhcp il vostro computer.

bibliobox11

Comparirà la seguente schermata:

bibliobox12

Passo 10

Utilizzare il comando passwd per impostare la password di accesso, questa password consentirà l’uso di SSH.:

passwd

bibliobox13

Passo 11

Aprite il file network con vi (vi elenco comandi ):

vi /etc/config/network

bibliobox15

Modificate il file secondo quanto indicato di seguito e inserendo gli indirizzi ip compatibili con la vostra rete locale. Nel mio caso l’indirizzo IP del router è 192.168.0.1, se il vostro è diverso dovete fare le opportune modifiche al file network. Cosa molto importante è che che il vostro PirateBox non dovrebbe avere, a regime, lo stesso gateway del router di casa altrimenti dalla PirateBox potrete uscire su internet. In questa fase di installazione abbiamo necessità di assegnare alla PirateBox lo stesso gateway del router di casa perché dobbiamo procedere con l’installazione, lo cambieremo quando avremo terminato.

bibliobox16

config interface ‘loopback’
       option ifname ‘lo’
       option proto ‘static’
       option ipaddr ’127.0.0.1′
       option netmask ’255.0.0.0′

config interface ‘lan’
       option ifname ‘eth0′
       option type ‘bridge’
       option proto ‘static’
       option ipaddr ’192.168.0.68′
       option netmask ’255.255.255.0′
       option gateway ’192.168.0.1′
       list dns ’192.168.0.1′
       list dns ’8.8.8.8′

Passo 12

Da quanto potete vedere nel file di configurazione l’IP che ho assegnato in questo momento alla PirateBox è: 192.160.0.68

Togliete alimentazione alla PirateBox e accendete il WiFi del vostro computer.

Passo 13

Collegate la PirateBox al router di casa ed accendete la PirateBox.

Passo 14

Aprite il terminale ed accedete come utente amministratore con il comando:

sudo su

inserite la vostra password di amministratore

piratebox34

Passo 15

Effettuate un collegamento ssh sula PirateBox:

ssh root@192.168.0.68

piratebox31

inserite la password che avete creato al passo 10:

piratebox23

Siete sulla PirateBox! Verificate se siete in grado di uscire su internet facendo un ping su google.com

ping www.google.com

piratebox24

Se uscite su internet dovreste avere una risposta simile a questa:

piratebox25

Interrompiamo la sequenza con un ctrl+C

piratebox26

Passo 16

Procediamo ora con l’installazione della PirateBox.

Collegate la chiavetta USB, formattata FAT32 con una sola partizione alla porta USB della vostra PirateBox.

Installiamo il pacchetto mkPirateBox con i seguenti comandi:

cd /tmp
 opkg update && opkg install http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk

piratebox27

piratebox28

piratebox29

Al termine dell’installazione vi verrà richiesto di riavviare la PirateBox

piratebox33

Passo 17

Completata l’installazione scollegate il cavo ethernet e l’alimentazione per almeno 10 secondi.

Passo 18

Ricollegate la PirateBox all’alimentazione e al router di casa vostra, dovreste notare la nuova rete WiFi: PirateBox – Share Freely.

piratebox35

Collegatevi nuovamente in ssh alla PirateBox e come fatto al passo 11 e modificate nuovamente il file network assegnando i valori originari

vi /etc/config/network

config interface ‘loopback’
       option ifname ‘lo’
       option proto ‘static’
       option ipaddr ’127.0.0.1′
       option netmask ’255.0.0.0′

config interface ‘lan’
       option ifname ‘eth0′
       option type ‘bridge’
       option proto ‘static’
       option ipaddr ’192.168.1.1′
       option netmask ’255.255.255.0′

Passo 19

Scollegate il cavo ethernet e scollega l’alimentazione per almeno 10 secondi, riavviate e dovreste vedere dopo qualche secondo la rete: “PirateBox – Share -Freely”. Aprite una pagina web e dovreste essere reindirizzati sulla pagina principale PirateBox.

A questo punto potete condividere file e chatare.

tp-link-mr3020-07

Passo 20

Incominciamo ora la trasformazione, diamo alla PirateBox una grafica più accattivante, (facendo scomparire il teschio, che per alcuni colleghi non molto techno-oriented potrebbe sembrare qualcosa di pericoloso 🙂 ).

Procediamo con l’installazione di una grafica, per far questo Roberto aveva realizzato la traduzione di Thomas Fourmeux che aveva realizzato un’interfaccia grafica, io ho sperimentato il tutto è funziona, sto realizzando un’ulteriore interfaccia grafica dove sto aggiungendo la possibilità di togliere alla bisogna il modulo di chat all’interno della rete delle BiblioBox.

La necessità di cambiare grafica nasce anche dall’esigenza di trovare un design responsive, ovvero che si adatti ad ogni tipo di dispositivo (PC, tablet, smartphone), ma come procedere?

Sylvain Naudin ha realizzato il riadattamentosu cui ho fatto le dovute modifiche, potete scaricarla al seguente link. Roberto ne ha fatto la traduzione italiana che potete scaricare al aseguente link ed io ho provveduto a fare alcune variazioni e realizzare una versione senza il modulo del caricamento dei file, la gestione è affidata solamente all’amministratore, mentre gli utenti fruiscono solo dei contenuti.

Prima di procedere effettuate una copia di tutti i file che sono presenti nella chiavetta USB, è sufficiente inserire la chiavette nel computer e copiare tutti i file.

Passo 21

Scaricate WinSCP o un qualsiasi software per il vostro SO che vi consente di connettervi in maniare sicura in modalità SFTP o FTP e che supporti il protocollo legacy SCP. (Nell’esempio ho usato Wine per usare WinSCP)

Passo 22

Collegate sia il cavo ethernet che il cavo USB della BiblioBox al computer.

Passo 23

Se necessario cambiate l’IP del vostro computer in modo che sia compatibile con quello del router (BiblioBox) questa l’impostazione che ho assegnato io dal mio computer:

BiblioBox-grafica01

Passo 24

Avviate  WinSCP ed inserite il nome dell’host e il numero di porta (22), nome utente e password, così come indicato nelle immagini che seguono.

BiblioBox-grafica02

doppio click su “WinSCP.exe

BiblioBox-grafica03

Selezionare SCP come protocollo:

BiblioBox-grafica04

Se non lo avete cambiato il nome utente è: root mentre la password quella che avete assegnato in fase di installazione (quella che avete usato per accedere in SSH). Come numero di porta lasciate 22.

Se avete inserito i parametri giusti dovreste trovarvi in una situazione simile a quella dell’immagine che segue:

BiblioBox-grafica05

Nella parte finistra della finestra fate click sulla cartella “root”:

BiblioBox-grafica06

Andate nella cartella:

/opt/ PirateBox /www

BiblioBox-grafica07

Selezionate, nella parte sinistra di WinSCP la cartella contenente i file con la nuova grafica della BiblioBox che avete precedentemente scaricato, nel mio caso come potete vedere nell’immagine che segue la posizione della cartella è in:

C:\users\maffucci\Desktop\www

BiblioBox-grafica08

Trasferite tutti i file (cartella compresa) che sitrovano nella parte sinistra di WinSCP sulla BiblioBox, sovrascrivete pure il file index.html.

Una volta concluso il trasferimento interrompete la connessione con la vostra BiblioBox facendo click sul pulsante in basso “F10 Esci”:

BiblioBox-grafica09

Comparirà una finestra di Alert che vi chiede se siete sicuri di voler chiudere la connessione, click su “ok” per confermare:

BiblioBox-grafica10

Adesso siete pronti per usare la vostra BiblioBox, collegatevi alla rete  WiFi: ”PirateBox – Share -Freely”. Aprite una pagina web e dovreste essere reindirizzati sulla pagina principale PirateBox, se ciò non accade digitate come URL: piratebox.lan oppure l’IP: 192.168.1.1

BiblioBox su iPhone

bibliobox-iphone

BiblioBox su iPad mini

bibliobox-ipad-mini

 

 

Articoli simili:

Questa voce è stata pubblicata in elettronica, i miei allievi, programmazione, tutorial e contrassegnata con , , , . Contrassegna il permalink.

6 risposte a Condividiamo la conoscenza – costruiamo una BiblioBox

  1. nilocram scrive:

    Grazie per le citazioni, ma devo ricordare che buona parte dei meriti vanno a Massimo Bernardi e Giovanni Mojoli che mi hanno sostenuto nelle traduzioni e soprattutto hanno riparato i danni che ho fatto da riga di comando 😉
    Ecco l’indirizzo di una paginetta di risorse sulla PirateBox in biblioteca:
    http://23cose.wikispaces.com/Pirate+Box+in+biblioteca
    e quello di un manifesto delle PirateBox in biblioteca:
    https://bibliobox.wikispaces.com/Manifesto+delle+PirateBox+in+biblioteca

    Grazie ancora e buon lavoro

    roberto

  2. Renato58 scrive:

    Non mi è chiara un cosa: la TP-LINK TL-WR702N ha una sola porta mini usb . Se la uso per la chiavetta usb, dove collego il cavo power?
    Grazie

    • admin scrive:

      Ciao Renato.

      Il TP-LINK TL-WR702N oltre al connettore mini USB, possiede lateralmente un connettore USB femmina di tipo B dove potrai collegare la tua chiavetta USB.

      Ciao.

  3. Oscar Piana scrive:

    Ma quanti device si riescono a collegare contemporaneamente con il wifi della Piratebox?
    Lo chiedo perché mi piacerebbe sperimentarla in classe (ho una cl@sse 2.0), ma temo che la connessione contemporanea di 20 notebook alle risorse della chiavetta non sia sostenibile. Se invece lo è, mi metto immediatamente all’opera!
    Grazie,
    Oscar

  4. Christian scrive:

    Salve, volevo chiederle una informazione
    ho provato con degli allievi a creare questa Bibliobox,
    ma ci siamo bloccati al passo 9, ora la TP-link-MR3020 tramite telnet non mi si apre più e non mi chiede la psw ( che purtroppo i miei allievi non si ricordano che rabbia). Come posso resettare il tutto e ripartire da zero ?
    Grazie mille
    Christian

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *